miniupnp.tuxfamily.org Forum Index miniupnp.tuxfamily.org
The forum about miniupnp and libnatpmp
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

ubuntu-transmission 1.60: Unable to open port

 
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpc Bugs
View previous topic :: View next topic  
Author Message
rirad



Joined: 12 May 2009
Posts: 3

PostPosted: Tue May 12, 2009 12:05 pm    Post subject: ubuntu-transmission 1.60: Unable to open port Reply with quote

I am using transmission 1.60 in Ubuntu 9.04 (64 bit) but I have slow transmission speeds with the latest release (1.60). Furthermore, when transmission is running also my internet connection (web speeds) seems to be severely reduced as if the router is unable to handle the traffic. I use the wrt610N router.
In transmission I opened the debug log. The relevant sections can be seen below.

From the debug information it seems that transmission thinks the port is opened successfully. When I check if this port is open in transmission (in preference - network) it says its closed. Also an online portscanning tools does not get a response from this port.
After a while transmission checks to see if the port is still open and finds that the port is closed and reopens it. Again thinking the port is open while in reality its not.

In previous versions of transmission this did work (I think it was 1.52).
---update--
I just found the debs 1.52 common and gtk debs and installed those but now the ports are also not opened. Is it possible that this is related to ubuntu 9.04?). So in 9.04 port opening does not work for me with transmission 1.51, 1.52 and 1.60. I am not sure which version of minupnp they use and if the version is also downgraded when I went from 1.60 to 1.51
---update---

I hope this report helps (PS ufw = inactive and upnp is enabled in the router)

(http changed to hxxp since I was not allowed to post links)

---edit ---
by mistake I wrote I used Ubuntu 9.10 but this must be 9.04. I corrected this
---edit----

Tue May 12 13:18:43 2009 debug setrlimit( RLIMIT_NOFILE, 712 )
Tue May 12 13:18:43 2009 debug 200 usable file descriptors


Tue May 12 13:18:43 2009 RPC Server Adding address to whitelist: 127.0.0.1
Tue May 12 13:18:43 2009 Transmission 1.60 (8339) started

Tue May 12 13:18:44 2009 Port Forwarding (NAT-PMP) initnatpmp succeeded (0)
Tue May 12 13:18:44 2009 Port Forwarding (NAT-PMP) sendpublicaddressrequest succeeded (2)
Tue May 12 13:18:46 2009 Port Forwarding (UPnP) Found Internet Gateway Device "hxxtp://192.168.1.1:5431/uuid:0023691a-a039-0023-691a-a03902000000/WANPPPConnection:1"
Tue May 12 13:18:46 2009 Port Forwarding (UPnP) Local Address is "192.168.1.30"
Tue May 12 13:18:46 2009 Port Forwarding (UPnP) Port forwarding through "hxxp://192.168.1.1:5431/uuid:0023691a-a039-0023-691a-a03902000000/WANPPPConnection:1", service "urn:schemas-upnp-org:service:WANPPPConnection:1". (local address: 192.168.1.30:43942)
Tue May 12 13:18:46 2009 Port Forwarding (UPnP) Port forwarding successful!
Tue May 12 13:18:46 2009 Port Forwarding State changed from "Not forwarded" to "Forwarded"
Tue May 12 13:18:46 2009 debug Bound socket 23 to port 43942 on 0.0.0.0
Tue May 12 13:18:46 2009 Port Forwarding Opened port 43942 on 0.0.0.0 to listen for incoming peer connections
Tue May 12 13:18:46 2009 debug Bound socket 24 to port 43942 on ::
Tue May 12 13:18:46 2009 Port Forwarding Opened port 43942 on :: to listen for incoming peer connections
Tue May 12 13:18:52 2009 debug Port Forwarding (NAT-PMP) readnatpmpresponseorretry failed. natpmp returned -7 (the gateway does not support nat-pmp); errno is 111 (Connection refused)

Tue May 12 13:38:43 2009 Port Forwarding Checking to see if port 43942 is still open
Tue May 12 13:38:43 2009 Port Forwarding (UPnP) Port 43942 isn't forwarded
Tue May 12 13:38:43 2009 Port Forwarding (UPnP) Port forwarding through "hxxp://192.168.1.1:5431/uuid:0023691a-a039-0023-691a-a03902000000/WANPPPConnection:1", service "urn:schemas-upnp-org:service:WANPPPConnection:1". (local address: 192.168.1.30:43942)
Tue May 12 13:38:43 2009 Port Forwarding (UPnP) Port forwarding successful!


Last edited by rirad on Thu May 14, 2009 10:01 am; edited 1 time in total
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1525

PostPosted: Wed May 13, 2009 8:14 pm    Post subject: Reply with quote

what is your router brand and model ?
have you tested UPnP with some other software ?
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
rirad



Joined: 12 May 2009
Posts: 3

PostPosted: Thu May 14, 2009 9:59 am    Post subject: Reply with quote

My router is the Linksys WRT610N (http://www.linksysbycisco.com/US/en/products/WRT610N)
I have used upnp in transmission successfully before (I can't remember it exactly anymore but I am pretty sure this was with transmission 1.52 in Ubuntu 8.10)

Can you suggest me another program or test routine that I can use to test upnp?

In my fist post I wrote I used Ubuntu 9.10 but this must be 9.04 (latest official release). This is corrected now.
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1525

PostPosted: Thu May 14, 2009 10:23 am    Post subject: Reply with quote

you should try the upnpc test program from the miniupnpc package.
It includes commands to add/remove and list redirections.
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
rirad



Joined: 12 May 2009
Posts: 3

PostPosted: Mon Aug 03, 2009 7:17 pm    Post subject: Reply with quote

It appeared that the firmware for the wrt610n was faulty. The recent update to 1.00.03.B15 (FW_WRT610N_1.00.03.15_20090514) fixed this problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpc Bugs All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP
© 2007 Thomas Bernard, author of MiniUPNP.