miniupnp.tuxfamily.org Forum Index miniupnp.tuxfamily.org
The forum about miniupnp and libnatpmp
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

P2P port forwarding: Cannot connect the forwarded port

 
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> NAT/UPnP
View previous topic :: View next topic  
Author Message
itswaqasliaqat



Joined: 14 Jun 2011
Posts: 2

PostPosted: Tue Jun 14, 2011 9:33 am    Post subject: P2P port forwarding: Cannot connect the forwarded port Reply with quote

Hi

I am implementing a P2P application which should be accessible from the internet. I am using UPnP to forward my local port on the NAT. Means the scenario is,

PC -----> (private IP) NAT (public IP) ------>Internet

The NAT setting are showing me required port mapping, means I can successfully add an entry with UPnP (miniupnpc) but its not opening a port at the router.

So now after opening a listening socket at local machine and port forwarding, I am not able to cannect via TCP socket to the NAT public ip:forwarded.port, It give me connection timeout. Its not loopback error, I tried with a separate internet line, but still its giving timeout.

thanks
itswaqasliaqat
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1442

PostPosted: Tue Jun 14, 2011 6:14 pm    Post subject: Reply with quote

Nobody can help you without more details :
What is the OS of your PC ? Does it have some firewall software installed ?
What is your router ?

Have you tried to use some other UPnP enabled software ? (P2P client client or chat software etc.)
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
itswaqasliaqat



Joined: 14 Jun 2011
Posts: 2

PostPosted: Wed Jun 15, 2011 9:44 am    Post subject: Reply with quote

Hi
I figured it out what the problem was. Actually I was using my company domain login and user group firewall policy was blocking all my requests by default despite of open ports at my local firewall. I run the code outside my company domain and it works fine.

Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> NAT/UPnP All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP
© 2007 Thomas Bernard, author of MiniUPNP.