miniupnp.tuxfamily.org Forum Index miniupnp.tuxfamily.org
The forum about miniupnp and libnatpmp
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

recvfrom(natpmp): Socket operation on non-socket

 
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpd Bugs
View previous topic :: View next topic  
Author Message
metalliqaz



Joined: 13 Mar 2012
Posts: 6

PostPosted: Tue Mar 13, 2012 1:37 am    Post subject: recvfrom(natpmp): Socket operation on non-socket Reply with quote

Hi all,

Running miniupnpd 1.4 from pkgsrc on NetBSD 6.

Check out /var/log/messages...

Code:

Mar 12 21:24:18 stripe miniupnpd[1779]: HTTP listening on port 65481
Mar 12 21:24:18 stripe miniupnpd[1779]: recvfrom(natpmp): Socket operation on non-socket
Mar 12 21:24:38 stripe syslogd[188]: last message repeated 122520 times
Mar 12 21:24:42 stripe syslogd[188]: last message repeated 26861 times
Mar 12 21:24:42 stripe miniupnpd[1779]: received signal 15, good-bye
Mar 12 21:24:42 stripe miniupnpd[1779]: recvfrom(natpmp): Socket operation on non-socket


Look at the timestamps. In 20 seconds, it sent that error over 122 thousand times!!! I notice that it mentions natpmp, yet my config file has natpmp turned off...

Code:

ext_ifname=xennet0
listening_ip=192.168.1.1/24
port=0
enable_natpmp=no
enable_upnp=yes
bitrate_up=1000000
bitrate_down=10000000
secure_mode=no
system_uptime=yes
notify_interval=60
clean_ruleset_interval=600
uuid=ac5c39e9-1c32-4b37-a1a0-e290b4fd7011
serial=12345678
model_number=1
allow 1024-65535 192.168.1.0/24 1024-65535
deny 0-65535 0.0.0.0/0 0-65535


My internal interface is bound to 192.168.1.1 netmask 255.255.255.0. My external interface is indeed xennet0.
This is NetBSD, therefore ipfilter.

Thanks for any help.

UPDATE
By the way, If I enable natpmp (enable_natpmp=yes), then the problem disappears and it stops eating 20% of my processor sending errors. There seems to be a problem implementing that config option.
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1500

PostPosted: Tue Mar 13, 2012 5:23 pm    Post subject: Reply with quote

huhu I should have a look at this. Anyway, does this also happen with miniupnpd-1.5 ? (or the latest version ?)
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
metalliqaz



Joined: 13 Mar 2012
Posts: 6

PostPosted: Wed Mar 14, 2012 1:30 am    Post subject: Reply with quote

I got 1.6 compiled and running. Seems to be fixed in the new version.

-d
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpd Bugs All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP
© 2007 Thomas Bernard, author of MiniUPNP.