miniupnp.tuxfamily.org Forum Index miniupnp.tuxfamily.org
The forum about miniupnp and libnatpmp
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Cannot link to device's web page

 
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpd Bugs
View previous topic :: View next topic  
Author Message
A_380_2009



Joined: 22 Mar 2012
Posts: 17

PostPosted: Thu Apr 12, 2012 7:19 am    Post subject: Cannot link to device's web page Reply with quote

I am trying to realize the device presentation function,now I can found the router icon from the network neiborhood, but when double click the the device icon, it will prompt that "The device you are trying to use is not currently available on your network. Check to see if the device is on the network and try again".
I analysed the process from the wireshark and found that the normally process of link to device's web page is:
1.The control point send a udp multicast M-search as below:
Code:
M-SEARCH * HTTP/1.1
Host:239.255.255.250:1900
ST:uuid:62b2670d-888a-4ea0-9872-522674e2f63c
Man:"ssdp:discover"
MX:3


2.The device unicast the respond HTTP ok to the control point as below:

Code:
HTTP/1.1 200 OK
Cache-Control: max-age=120
ST: uuid:62b2670d-888a-4ea0-9872-522674e2f63c
USN: uuid:62b2670d-888a-4ea0-9872-522674e2f63c::uuid:62b2670d-888a-4ea0-9872-522674e2f63c
EXT:
Server: MF60/1.0 UPnP/1.0 miniupnpd/1.0
Location: http://192.168.1.1:1900/rootDesc.xml


3.The control point send a TCP GET request as below:

4.The device respond this request with device description XML
5.OK,we can load the web browser
But now my issue is when I double click the device icon,the control point will send the udp M-search request and the device have already respond the HTTP OK.But the control point will not send the TCP GET request any more.So I doubt that there was something wrong with the UDP respond.
After different kinds of debug I can not found the mistake,so would you pls tell me the probable mistake.I wouder that why I can found upnp icon from the device neiborhood but can not load the web browser.
Below was the wireshark contents when I double click the icon:
1. The M-search request from the control point:
Code:
M-SEARCH * HTTP/1.1
Host:239.255.255.250:1900
ST:uuid:12345678-0000-0000-0000-00000000abcd
Man:"ssdp:discover"
MX:3

2. The respond from the device
Code:
HTTP/1.1 200 OK
CACHE-CONTROL: max-age=120
ST: uuid:12345678-0000-0000-0000-00000000abcd
USN: uuid:12345678-0000-0000-0000-00000000abcd::uuid:12345678-0000-0000-0000-00000000abcd
EXT:
SERVER: Eufi890/1.0 UPnP/1.0 MiniUPnPd/1.0
LOCATION: http://192.168.1.1:1900/rootDesc.xml


That's all,thank you very much![/code]
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1497

PostPosted: Thu Apr 12, 2012 9:47 am    Post subject: Reply with quote

Why are the uuid different ?
uuid:62b2670d-888a-4ea0-9872-522674e2f63c then uuid:12345678-0000-0000-0000-00000000abcd ?
If uuid is changing, windows will think it is a different device !
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
A_380_2009



Joined: 22 Mar 2012
Posts: 17

PostPosted: Thu Apr 12, 2012 12:17 pm    Post subject: Reply with quote

Well,the uuid:62b2670d-888a-4ea0-9872-522674e2f63c was captured from the normally router, and the uuid:12345678-0000-0000-0000-00000000abcd was captured from the router which can not log in the web browser Very Happy
Thanks!
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1497

PostPosted: Thu Apr 12, 2012 4:55 pm    Post subject: Reply with quote

well, you should first try to set up a correct uuid...
Code:
make uuid
or something like that.

Also, could you please give the presentationURL from both XML descriptions (working and non working router)
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
A_380_2009



Joined: 22 Mar 2012
Posts: 17

PostPosted: Fri Apr 13, 2012 6:03 am    Post subject: Reply with quote

The uuid about the working router which was generated in the souce code was:
    uuid:62b2670d-888a-4ea0-9872-522674e2f63c

The uuid which I use was:
    uuid:62b2670d-888a-4ea0-9872-522674e2f63d

As you can see, it's not generated by your code and was imitated the uuid of working router. And I wonder that does this uuid correct or incorrect if I can ensure it's unique in the LAN even if it's not follow your method in the souce code.

the presentationURL from device descriptions of working router:
    <presentationURL>http://192.168.1.1/</presentationURL>

the presentationURL from device descriptions of non working router:
    <presentationURL>http://192.168.1.1/</presentationURL>

I doubt the reason cannot log in the webui was not because of the
presentationURL,because the control point can not send get XML description request,so I think it has nothing to do with the presentationURL now.

And I want to discuss with you about my application:
The upnp function which I want to realize was listed as below:
1.Find the upnp device ,then I can find the upnp icon from the network neiborhood.(have already realized)
2.Double click the icon to log in the webUI.
As you can see, it has nothing to do with the NAT,port mapping...
So in the device description ,I "cust" the embedeed device of WANDevice & WANConnection Device from <deviceList>,and I reserved the rootdevice and the serviceList of rootdevice as you can see in the non-working XML.
That's what I did before,does it have any relationship with the behavior of "cust" the embedeed device?
The non-working device description XML was:

    HTTP/1.1 200 OK
    Content-Type: text/xml
    Connection: close
    Content-Length: 936
    Server: Eufi890/1.0 UPnP/1.0 MiniUPnPd/1.0

    <?xml version="1.0"?>
    <root
    xmlns="urn:schemas-upnp-org:device-1-0">
    <specVersion>
    <major>1</major>
    <minor>0</minor>
    </specVersion>
    <device>
    <deviceType>urn:schemas-upnp-org:device:InternetGatewayDevice:1</deviceType>
    <friendlyName>Eufi890 router</friendlyName>
    <manufacturer>Eufi890</manufacturer>
    <manufacturerURL>http://vz.hotspot/</manufacturerURL>
    <modelDescription>Eufi890 router</modelDescription>
    <modelName>Eufi890 router</modelName>
    <modelNumber>1</modelNumber>
    <modelURL>http://vz.hotspot/</modelURL>
    <serialNumber>12345678</serialNumber>
    <UDN>uuid:62b2670d-888a-4ea0-9872-522674e2f63d</UDN>
    <serviceList>
    <service>
    <serviceType>urn:schemas-upnp-org:service:Layer3Forwarding:1</serviceType>
    <serviceId>urn:upnp-org:serviceId:Layer3Forwarding1</serviceId>
    <controlURL>/ctl/L3F</controlURL>
    <eventSubURL>/evt/L3F</eventSubURL>
    <SCPDURL>/L3F.xml</SCPDURL>
    </service>
    </serviceList>
    <presentationURL>http://192.168.1.1/</presentationURL>
    </device>
    </root>


I wan to upload the wireshark captured from the control point but I dont konw how to do.So I have to paste the XML...
Thank you very much!
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1497

PostPosted: Fri Apr 13, 2012 1:01 pm    Post subject: Reply with quote

Windows may be a little "touchy" about the XML description of the IGD...
You should ask Microsoft what you can remove in it.
Clearly a IGD that is not offering the WANIPConnection or WANPPPConnection service is useless.
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
A_380_2009



Joined: 22 Mar 2012
Posts: 17

PostPosted: Mon Apr 16, 2012 2:42 am    Post subject: Reply with quote

I will try to find out the reason.
please tell me whether my idea about the UUID I described above is correct?
Thanks.
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1497

PostPosted: Mon Apr 16, 2012 12:30 pm    Post subject: Reply with quote

A_380_2009 wrote:
I will try to find out the reason.
please tell me whether my idea about the UUID I described above is correct?

I dont know. You'd better use a uuid generator tool.
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
A_380_2009



Joined: 22 Mar 2012
Posts: 17

PostPosted: Thu Apr 19, 2012 2:51 am    Post subject: Reply with quote

Hello:
I have solved the problem about can not log in the browser, because of the invalid checksum of udp.
At lease it proved that:
1. If I can ensure the uuid is unique within the LAN,it works!
2. If removed the embeded device and the embeded service in the Device Description XML,it works!
Thank you for your support!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpd Bugs All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP
© 2007 Thomas Bernard, author of MiniUPNP.