miniupnp.tuxfamily.org Forum Index miniupnp.tuxfamily.org
The forum about miniupnp and libnatpmp
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Interface detection

 
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpd Bugs
View previous topic :: View next topic  
Author Message
twear



Joined: 01 Nov 2012
Posts: 80

PostPosted: Thu Mar 07, 2013 1:07 am    Post subject: Interface detection Reply with quote

For some reason when I start up MiniUPnPd with an interface in the .conf file which is not present, MiniUPnPd is still able to find the correct interface and run. It used to end with an error, at least I thought so. This is anoying since I only want it to run on particular interfaces.

Also, can MiniUPnPd run on multiple interfaces at the same time? or is it limited to just one.

Last question, specifying an interface via the command line should overwrite any in the conf file correct? I can't really test this due to the first issue I'm having...

Thanks
Back to top
View user's profile Send private message
twear



Joined: 01 Nov 2012
Posts: 80

PostPosted: Fri Mar 08, 2013 12:41 am    Post subject: Reply with quote

A more detailed explanation.

I have 2 network interfaces, wlan0 and wlan1. For some reason no matter what I do I can not get MiniUPnPd to run on wlan1. I have changed the conf file to just wlan1, over ridden using command line, just about everything I can think of.

The goal is to get MiniUPnPd running on both...
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1518

PostPosted: Tue Mar 12, 2013 11:04 pm    Post subject: Reply with quote

well you should have at least 2 network interface for MiniUPnPd to be useful for something:)
one for LAN, one for WAN (internet).
what do you mean by "run on wlan1" ? is wlan0 on LAN and wlan1 on WAN ? or the opposite ?
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
twear



Joined: 01 Nov 2012
Posts: 80

PostPosted: Wed Mar 13, 2013 5:53 pm    Post subject: Reply with quote

I was mixing up the wan and lan interfaces in the config file, everything works fine.

thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpd Bugs All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP
© 2007 Thomas Bernard, author of MiniUPNP.