miniupnp.tuxfamily.org Forum Index miniupnp.tuxfamily.org
The forum about miniupnp and libnatpmp
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Presentation Page format

 
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpd Bugs
View previous topic :: View next topic  
Author Message
twear



Joined: 01 Nov 2012
Posts: 80

PostPosted: Thu May 23, 2013 9:33 pm    Post subject: Presentation Page format Reply with quote

Not sure if this an error, in the code it looks to be alright...
But I'm failing conformance test case: UDA-5.0.1 Presentation page format

ERROR: "CONTENT-LANGUAGE" header is missing in response, however "ACCEPT-LANGUAGE" header is specified in request

from the code it looks like the Content language should be sent back, but isn't. Wasn't sure if you had seen this before. I'll look more into it and update if I find anything
Back to top
View user's profile Send private message
twear



Joined: 01 Nov 2012
Posts: 80

PostPosted: Thu May 23, 2013 10:32 pm    Post subject: Reply with quote

So i got pass that error, the problem was due to another http server running.

But now I am getting other errors:
No response has been received. Expected: "2xx". Error info: "ConnectFailure"
Cannot download presentation page

Is there a presentation page with MiniUPnPd or is this something I need to implement
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1442

PostPosted: Fri May 24, 2013 12:02 am    Post subject: Reply with quote

miniupnpd is not supplying the presentation Smile you should have another webserver... Usually the router has a web interface, so the <presentationURL> element in the UPNP description is pointing to it.
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
twear



Joined: 01 Nov 2012
Posts: 80

PostPosted: Mon Jun 10, 2013 7:03 pm    Post subject: Reply with quote

So I'm still looking into this, haven't been able to fix it yet.

But it looks like the HTTP GET is querying for /rootDesc.xml, /L3F.xml, /WANCfg.xml, and /WANIPCn.xml. Not the presentation URL.

I compared the response to that of MiniDLNA, which I am also running, and which is passing this certification test.

MiniUPnPd returns:
HTTP connection from 192.168.225.22:50196
get_lan_for_peer(): found in LAN bridge0 192.168.225.1

but MiniDLNA returns:
Quote:
[1980/01/06 00:29:14] minidlna.c:1200: debug: HTTP connection from 192.168.225.22:64690
[1980/01/06 00:29:14] upnphttp.c:948: debug: HTTP REQUEST: GET / HTTP/1.1
ACCEPT-LANGUAGE: en
Host: 192.168.225.1:8200


[1980/01/06 00:29:14] upnphttp.c:1272: debug: HTTP RESPONSE: HTTP/1.1 200 OK
Content-Type: text/html
Connection: close
Content-Length: 183
Server: Ubuntu/10.04 DLNADOC/1.50 UPnP/1.0 MiniDLNA/1.0.25
Content-Language: en
Date: Sun, 06 Jan 1980 00:29:14 GMT
EXT:

<HTML><HEAD><TITLE>MiniDLNA 1.0.25</TITLE></HEAD><BODY><div style="text-align: center"><h3>MiniDLNA status</h3>Audio fil
es: 0<br>Video files: 0<br>Image files: 0</div></BODY></HTML>


This is via the debug prints, I'm trying to confirm in wireshark right now, but it looks like MiniUPnPd is in fact doing something wrong, I just haven't figured out what yet. It looks like MiniUPnPd isn't processing the http get response for some reason...
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1442

PostPosted: Mon Jun 10, 2013 7:30 pm    Post subject: Reply with quote

you have not understood :
presentation is not implemented by MiniUPnPd. You either have to remove <presentationURL> element from the description, either make it point to another webserver.

As I have already written here, usualy the routers have an admin web interface, and <presentationURL> points to it.
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
twear



Joined: 01 Nov 2012
Posts: 80

PostPosted: Mon Jun 10, 2013 8:08 pm    Post subject: Reply with quote

what I'm saying is that I don't believe this has anything to do with the presentation url. At first I did, but looking at the test more closely, it does not appear that is the case
Back to top
View user's profile Send private message
twear



Joined: 01 Nov 2012
Posts: 80

PostPosted: Mon Jun 10, 2013 8:15 pm    Post subject: Reply with quote

specifically I'm looking at the "BuildHeader_upnphttp" function in upnphttp.c which seams to be handling this test case.

I can start a new thread for this if you wish, since the title is miss leading to what is actually happening
Back to top
View user's profile Send private message
twear



Joined: 01 Nov 2012
Posts: 80

PostPosted: Mon Jun 10, 2013 9:59 pm    Post subject: Reply with quote

actually I'm really confused as to if it should be using the presentation URL or not... since MiniDLNA seams to have there own default presentation URL.

Either way it seems like the "GET" response is what is failing, and I'm not sure if that is being handled by MiniUPnPd or something else
Back to top
View user's profile Send private message
twear



Joined: 01 Nov 2012
Posts: 80

PostPosted: Mon Jun 10, 2013 10:49 pm    Post subject: Reply with quote

so you were right, took me forever to figure it all out, but I got it.

1 last question, any Idea how to get past authentication? for some reason the default pages on the device all require userName/password <--- also the reason why it's been failing all along
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1442

PostPosted: Tue Jun 11, 2013 9:10 am    Post subject: Reply with quote

twear wrote:
1 last question, any Idea how to get past authentication? for some reason the default pages on the device all require userName/password <--- also the reason why it's been failing all along

How can I have any idea ? I don't know which device you are talking about, which webserver it is, etc.
You should ask the developper
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
twear



Joined: 01 Nov 2012
Posts: 80

PostPosted: Tue Jun 11, 2013 4:41 pm    Post subject: Reply with quote

You seem to be all knowing, so I thought I would ask. But I figured it out so it's all good.

Thanks for the help
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpd Bugs All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP
© 2007 Thomas Bernard, author of MiniUPNP.