miniupnp.tuxfamily.org Forum Index miniupnp.tuxfamily.org
The forum about miniupnp and libnatpmp
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Trying to debug UPnP error

 
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> NAT/UPnP
View previous topic :: View next topic  
Author Message
ssjkakaroto



Joined: 31 May 2009
Posts: 10

PostPosted: Sat Jun 20, 2020 4:51 pm    Post subject: Trying to debug UPnP error Reply with quote

Hi there, my router used to have UPnP working without a problem until my ISP decided to update its firmware remotely. Now, when I use upnpc -l this is the response:
Code:
upnpc : miniupnpc library test client, version 2.1.
 (c) 2005-2020 Thomas Bernard.
Go to http://miniupnp.free.fr/ or https://miniupnp.tuxfamily.org/
for more information.
List of UPNP devices found on the network :
 desc: http://192.168.0.1:5431/dyndev/uuid:52681398-dc7c-4959-869d-68a244f89482
 st: urn:schemas-upnp-org:device:InternetGatewayDevice:1

Socket error: connect, 10061
No valid UPNP Internet Gateway Device found.

And no programs are able to use UPnP.

Any idea of what they could have done that have disabled UPnP?
Back to top
View user's profile Send private message
vayvanne



Joined: 18 Oct 2020
Posts: 3
Location: GB

PostPosted: Sun Oct 18, 2020 10:43 pm    Post subject: socket error 10061 Reply with quote

Quote:
because the target machine actively refused it

firewall?
Back to top
View user's profile Send private message
vayvanne



Joined: 18 Oct 2020
Posts: 3
Location: GB

PostPosted: Sun Oct 18, 2020 11:35 pm    Post subject: is not upnp router Reply with quote

my google wifi does not open a port for utorrent v2.2. I get
Quote:
[2020-10-18 00:10:00] UPnP: The device "WANConnectionDevice" is not a UPnP router (http://192.168.1.254:5000/rootDesc.xml)

windows 10 teredo, whatsapp and bitcoind are okay, upnp client software also does works but only for ipv4.
if I try
Code:
upnpc -e "uTorrent tcp" -A "" 6881 [my:ipv6:here] 6881 tcp 3600

I get
Quote:
upnpc : miniupnpc library test client, version 1.9.
(c) 2005-2014 Thomas Bernard.
Go to http://miniupnp.free.fr/ or http://miniupnp.tuxfamily.org/
for more information.
List of UPNP devices found on the network :
desc: http://192.168.1.254:5000/rootDesc.xml
st: urn:schemas-upnp-org:device:InternetGatewayDevice:1

Found valid IGD : http://192.168.1.254:5000/ctl/IPConn
Local LAN ip address : 192.168.1.24
AddPinhole([]:6881 -> [my:ipv6:here]:6881) failed with code 401 (Invalid Action)

rootDesc.xml content is
Code:
<root xmlns="urn:schemas-upnp-org:device-1-0">
<specVersion>
<major>1</major>
<minor>0</minor>
</specVersion>
<device>
<deviceType>urn:schemas-upnp-org:device:InternetGatewayDevice:2</deviceType>
<friendlyName>OnHub</friendlyName>
<manufacturer>Google</manufacturer>
<manufacturerURL>http://google.com/</manufacturerURL>
<modelDescription>Wireless Router</modelDescription>
<modelName>OnHub</modelName>
<modelNumber>1</modelNumber>
<modelURL>https://on.google.com/hub/</modelURL>
<serialNumber>00000000</serialNumber>
<UDN>uuid:416ef38b-6621-4a01-bf18-b37096031292</UDN>
<serviceList>
<service>
<serviceType>urn:schemas-upnp-org:service:Layer3Forwarding:1</serviceType>
<serviceId>urn:upnp-org:serviceId:Layer3Forwarding1</serviceId>
<controlURL>/ctl/L3F</controlURL>
<eventSubURL>/evt/L3F</eventSubURL>
<SCPDURL>/L3F.xml</SCPDURL>
</service>
<service>
<serviceType>urn:schemas-upnp-org:service:DeviceProtection:1</serviceType>
<serviceId>urn:upnp-org:serviceId:DeviceProtection1</serviceId>
<controlURL>/ctl/DP</controlURL>
<eventSubURL>/evt/DP</eventSubURL>
<SCPDURL>/DP.xml</SCPDURL>
</service>
</serviceList>
<deviceList>
<device>
<deviceType>urn:schemas-upnp-org:device:WANDevice:2</deviceType>
<friendlyName>WANDevice</friendlyName>
<manufacturer>MiniUPnP</manufacturer>
<manufacturerURL>http://miniupnp.free.fr/</manufacturerURL>
<modelDescription>WAN Device</modelDescription>
<modelName>WAN Device</modelName>
<modelNumber>20200916</modelNumber>
<modelURL>http://miniupnp.free.fr/</modelURL>
<serialNumber>00000000</serialNumber>
<UDN>uuid:416ef38b-6621-4a01-bf18-b37096031293</UDN>
<UPC>000000000000</UPC>
<serviceList>
<service>
<serviceType>urn:schemas-upnp-org:service:WANCommonInterfaceConfig:1</serviceType>
<serviceId>urn:upnp-org:serviceId:WANCommonIFC1</serviceId>
<controlURL>/ctl/CmnIfCfg</controlURL>
<eventSubURL>/evt/CmnIfCfg</eventSubURL>
<SCPDURL>/WANCfg.xml</SCPDURL>
</service>
</serviceList>
<deviceList>
<device>
<deviceType>urn:schemas-upnp-org:device:WANConnectionDevice:2</deviceType>
<friendlyName>WANConnectionDevice</friendlyName>
<manufacturer>MiniUPnP</manufacturer>
<manufacturerURL>http://miniupnp.free.fr/</manufacturerURL>
<modelDescription>MiniUPnP daemon</modelDescription>
<modelName>MiniUPnPd</modelName>
<modelNumber>20200916</modelNumber>
<modelURL>http://miniupnp.free.fr/</modelURL>
<serialNumber>00000000</serialNumber>
<UDN>uuid:416ef38b-6621-4a01-bf18-b37096031294</UDN>
<UPC>000000000000</UPC>
<serviceList>
<service>
<serviceType>urn:schemas-upnp-org:service:WANIPConnection:2</serviceType>
<serviceId>urn:upnp-org:serviceId:WANIPConn1</serviceId>
<controlURL>/ctl/IPConn</controlURL>
<eventSubURL>/evt/IPConn</eventSubURL>
<SCPDURL>/WANIPCn.xml</SCPDURL>
</service>
</serviceList>
</device>
</deviceList>
</device>
</deviceList>
<presentationURL>http://testwifi.here/</presentationURL>
</device>
</root>

appreciate any suggestions.
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1504

PostPosted: Mon Oct 26, 2020 7:59 am    Post subject: Reply with quote

Well You should look at http://192.168.1.254:5000/WANIPCn.xml
to see if AddPinhole() method is defined.

It may not be enabled.
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
vayvanne



Joined: 18 Oct 2020
Posts: 3
Location: GB

PostPosted: Wed Nov 11, 2020 6:05 pm    Post subject: AddPinhole Reply with quote

miniupnp wrote:
Well You should look at http://192.168.1.254:5000/WANIPCn.xml
to see if AddPinhole() method is defined.

It may not be enabled.

Spot on. No AddPinhole there. Will report to google. Thanks a lot.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> NAT/UPnP All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP
© 2007 Thomas Bernard, author of MiniUPNP.