miniupnp.tuxfamily.org Forum Index miniupnp.tuxfamily.org
The forum about miniupnp and libnatpmp
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

MiniUPNPD setup and configuration help

 
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpd Compilation/Installation
View previous topic :: View next topic  
Author Message
CarmeloLabadie



Joined: 18 Nov 2021
Posts: 1
Location: United States

PostPosted: Fri Nov 19, 2021 7:28 am    Post subject: MiniUPNPD setup and configuration help Reply with quote

I have installed MiniUPNPd for UPNP from the Quantal repository. I am using the latest Zentyal 3 version. No problems with the install whatsoever, its the configuration that has me puzzled. I was looking at the clearOS forum because they have this package for their OS and others have helped. I can't add the link

So I already have it installed and set the WAN interface to be my eth1 port and the listening IP Address to be 10.1.1.5 which is my lan IP Address on eth0. The part that I can't figure out is it implies that I have to make a manual entry in my IPTABLES for it to work. The instructions mention a script that runs during firewall start so I looked up the hooks for Zentyal and it says to use firewall.postservice for firewall scripts. So as root I created a file in /etc/zentyal/hooks/firewall.postservice and added the IPTABLES code:

##
#MINIUPNPD required tables
##
IPTABLES=/sbin/iptables
#EXTIF= (not required as uses automagic to determine WAN, can be manually specified)
#adding the MINIUPNPD chain for nat
$IPTABLES -t nat -N MINIUPNPD
#adding the rule to MINIUPNPD
$IPTABLES -t nat -A PREROUTING -i $EXTIF -j MINIUPNPD

#adding the MINIUPNPD chain for filter
$IPTABLES -t filter -N MINIUPNPD
#adding the rule to MINIUPNPD
$IPTABLES -t filter -A FORWARD -i $EXTIF -o ! $EXTIF -j MINIUPNPD

On firewall restart, it doesn't complain about an error, but when I run: iptables -L there are no listings for MINIUPNPD.

When I restart the miniupnpd service it does add its own chain but there are no values under it.

Just trying to get help from anyone who has worked with this. Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpd Compilation/Installation All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP
© 2007 Thomas Bernard, author of MiniUPNP.