miniupnp.tuxfamily.org Forum Index miniupnp.tuxfamily.org
The forum about miniupnp and libnatpmp
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

miniupnpd resets forwards on DHCP renew

 
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpd Bugs
View previous topic :: View next topic  
Author Message
tleeds



Joined: 02 Jan 2013
Posts: 1
Location: Newfoundland Canada

PostPosted: Wed Jan 02, 2013 3:44 am    Post subject: miniupnpd resets forwards on DHCP renew Reply with quote

Poking away at a problem on the Asus RT-N56u. Some ISP's are sending down 20 minute DHCP leases (meaning the DHCP daemon renews every 10 mins).

Seeing in the logs that miniupnpd drops all the forwards as stale even though the WAN IP hasn't changed.

Trying to determine if this is

A) An expected behaviour
B) A potential bug with the version of miniupnpd
C) A potential bug with something else the firmware causing miniupnpd to think the forwards are stale.

I'm having trouble determining the version of miniupnpd being used, but if I do/can, I'll update here. Any input would be welcome
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1497

PostPosted: Mon Jan 07, 2013 10:59 am    Post subject: Reply with quote

could you copy paste the log here ?
miniupnpd uses packet count on network interface to check if the redirection is "stale". Maybe theses counts are reset when DHCP lease is renewed ?
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
stevphie



Joined: 25 Apr 2013
Posts: 1

PostPosted: Thu Apr 25, 2013 2:56 am    Post subject: THIS IS SEVERE PROBLEM Reply with quote

This happen to latest snapshot build in openwrt (RC1, RC2 and Beta still works though)

I tried on my 2 different type router (tplink wrs543nd, tplink mr3420)

Not only after new DHCP Lease, but after an amount of minutes the NAT would break and cant find back my lan ip address.

Restart miniupnpd & firewall only still break it until restarting network though after amount of minutes it break again and upnp fail.


Sorry can't provide log cause i already flash back to openwrt 12.09 RC1 and it seems fine.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpd Bugs All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP
© 2007 Thomas Bernard, author of MiniUPNP.