miniupnp.tuxfamily.org Forum Index miniupnp.tuxfamily.org
The forum about miniupnp and libnatpmp
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Name of port forwarding rule

 
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpc Compilation/Installation
View previous topic :: View next topic  
Author Message
upnpuser



Joined: 29 Aug 2014
Posts: 1

PostPosted: Fri Aug 29, 2014 2:20 am    Post subject: Name of port forwarding rule Reply with quote

Hi there!
Is there a way to specify a name of a port forwarding rule?
On windows if I do
upnpc.exe -r 20001 TCP

it redirects the external router port 20001 TCP to the current local host ip with the same port 20001 TCP.
That is fine.However when I check the port forwarding on the IGD I see that same rule is named libminiupnpc.
The same name appears for any redirection created using upnpc.exe

So is there a way to specify different name?
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1445

PostPosted: Tue Sep 09, 2014 3:32 pm    Post subject: Reply with quote

use "-e" command line option
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
Mukatai



Joined: 25 Sep 2014
Posts: 5
Location: France

PostPosted: Thu Sep 25, 2014 3:07 pm    Post subject: Reply with quote

Hello,

I try to do the same, but it won't work.

When i use this commande (linux) :
upnpc-static -a 192.168.0.79 800 800 tcp -e Test

I have this error message :
AddPortMapping(800, 800, 192.168.0.79) failed with code 501 (Action Failed)

And when i use this command :
upnpc-static -e Test -a 192.168.0.79 800 800 tcp

The port are mapped but i have not description with upnp-static -l command

how to use -e parameter ?

Thanks.

Good Bye.
Back to top
View user's profile Send private message
Mukatai



Joined: 25 Sep 2014
Posts: 5
Location: France

PostPosted: Fri Sep 26, 2014 7:10 pm    Post subject: Reply with quote

Hello,

I tried another router and the second command works.

The router who don't work is a Technicolor TG789 but other applications can write the description.

Have you any idea ?

Bye.
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1445

PostPosted: Mon Sep 29, 2014 7:38 am    Post subject: Reply with quote

That is strange. I think I can test on a Technicolor TG789.
I will try
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
Mukatai



Joined: 25 Sep 2014
Posts: 5
Location: France

PostPosted: Mon Sep 29, 2014 8:20 am    Post subject: Reply with quote

Hello,

Ok If you want my help do not hesitate ...

(Skype, Teredo & Y-Cam camera can add description)

Thanks.

Bye.
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1445

PostPosted: Mon Sep 29, 2014 10:07 am    Post subject: Reply with quote

I tested with a TG788vn v2 and it works well...
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
Mukatai



Joined: 25 Sep 2014
Posts: 5
Location: France

PostPosted: Mon Sep 29, 2014 12:52 pm    Post subject: Reply with quote

After watching the html interface, I realize it is a TG788vn v2 with firmware 10.5.2.P, box of OVH Telecom. (Distinctive sign : the response time is very slow)

Is it the same for you ?

(I use miniupnpc-1.9.20140911 on Debian Wheezy 7.5 in VirtualBox and Debian Wheezy 7.5 on BeagleBone Black with same result, port mapped without description)

@+
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1445

PostPosted: Mon Sep 29, 2014 12:55 pm    Post subject: Reply with quote

yes it is the same router.
the -e option is working fine. Maybe "test" is not an allowed description Smile
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
Mukatai



Joined: 25 Sep 2014
Posts: 5
Location: France

PostPosted: Mon Sep 29, 2014 1:35 pm    Post subject: Reply with quote

lol no, it's not an allowed description.

But I saw other ports are opened without description by other programs, I decide reboot the router. Miracle It Works!

Sorry for the inconvenience, this is the first thing I should have done !

Thanks for your help and your work !

Bye.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpc Compilation/Installation All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP
© 2007 Thomas Bernard, author of MiniUPNP.