miniupnp.tuxfamily.org Forum Index miniupnp.tuxfamily.org
The forum about miniupnp and libnatpmp
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Peplink Balance One and No IGD UPnP Device found on the netw

 
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpc Bugs
View previous topic :: View next topic  
Author Message
MikeyCarter



Joined: 27 Feb 2015
Posts: 4
Location: Orangeville, ON

PostPosted: Fri Feb 27, 2015 3:14 am    Post subject: Peplink Balance One and No IGD UPnP Device found on the netw Reply with quote

I've got a Peplink Balance One as my gateway and I can see it's registered a bunch of upnp and NAT-PMP connections.

But with miniupnpc (aka bitcoins) I can't seem to get a connection working. Tried with just the client (not sure if I've got the command correct)

$ upnpc -a 172.29.0.73 9901 9901 tcp
upnpc : miniupnpc library test client. (c) 2005-2013 Thomas Bernard
Go to **** or *****
for more information.
No IGD UPnP Device found on the network !


Not sure where to go from here. Is this a miniupnpc problem or a problem with the Peplink side?

Package I'm using is : miniupnpc-1.9-4.fc21.x86_64 if it helps.
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1469

PostPosted: Mon Mar 02, 2015 9:35 am    Post subject: Re: Peplink Balance One and No IGD UPnP Device found on the Reply with quote

MikeyCarter wrote:

Not sure where to go from here. Is this a miniupnpc problem or a problem with the Peplink side?

I don't know. Are other software correctly seeing the UPNP IGD ?

You can check using wireshark/tshark/tcpdump/etc. if the UPNP IGD is correctly announcing itself using UDP broadcast on port 1900.

Code:
$ tcpdump -n -i ethX udp and port 1900

_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
MikeyCarter



Joined: 27 Feb 2015
Posts: 4
Location: Orangeville, ON

PostPosted: Mon Mar 02, 2015 4:18 pm    Post subject: Re: Peplink Balance One and No IGD UPnP Device found on the Reply with quote

miniupnp wrote:
MikeyCarter wrote:

Not sure where to go from here. Is this a miniupnpc problem or a problem with the Peplink side?

I don't know. Are other software correctly seeing the UPNP IGD ?

You can check using wireshark/tshark/tcpdump/etc. if the UPNP IGD is correctly announcing itself using UDP broadcast on port 1900.

Code:
$ tcpdump -n -i ethX udp and port 1900


Well I see chatter from the tcpdump.

Also /usr/bin/gupnp-universal-cp can discover the router no problem.
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1469

PostPosted: Mon Mar 02, 2015 11:29 pm    Post subject: Reply with quote

so it looks like there is an issue with miniupnpc.
Is miniupnpc sending correctly the SSDP M-SEARCH ?
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
MikeyCarter



Joined: 27 Feb 2015
Posts: 4
Location: Orangeville, ON

PostPosted: Tue Mar 03, 2015 1:40 am    Post subject: Reply with quote

miniupnp wrote:
so it looks like there is an issue with miniupnpc.
Is miniupnpc sending correctly the SSDP M-SEARCH ?


Still trying to get my head around this. When I run gupnp-universal-cp it sends a bunch of NOTIFY * HTTP/1.1 back. One being:

NOTIFY * HTTP/1.1
HOST:239.255.255.250:1900
Cache-Control:max-age=120
Location:http://172.29.0.6:48019/rootDesc.xml
Server: Linux/3.12.13-gentoo UPnP/1.0 MiniUPnPd/1.2
NT:urn:schemas-upnp-org:device:InternetGatewayDevice:1
USN:uuid:fc4ec57e-b051-11db-88f8-0060085db3f6::urn:schemas-upnp-org:device:InternetGatewayDevice:1
NTS:ssdp:alive

When I run: upnpc -s

I see:

M-SEARCH * HTTP/1.1
HOST: 239.255.255.250:1900
ST: urn:schemas-upnp-org:device:InternetGatewayDevice:1
MAN: "ssdp:discover"
MX: 2


And thee other's... but nothing is sent back.
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1469

PostPosted: Tue Mar 03, 2015 11:02 am    Post subject: Reply with quote

that is strange.
I suppose
upnpc -u http://172.29.0.6:48019/rootDesc.xml -l
works well Smile

anyway MiniUPnPd/1.2 is awfully old and buggy
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
MikeyCarter



Joined: 27 Feb 2015
Posts: 4
Location: Orangeville, ON

PostPosted: Tue Mar 03, 2015 1:29 pm    Post subject: Reply with quote

yep:

Code:
$ upnpc -u http://172.29.0.6:48019/rootDesc.xml -l
upnpc : miniupnpc library test client. (c) 2005-2014 Thomas Bernard
Go to http://miniupnp.free.fr/ or http://miniupnp.tuxfamily.org/
for more information.
Found valid IGD : http://172.29.0.6:48019/ctl/IPConn
Local LAN ip address : 172.29.0.73
Connection Type : IP_Routed
Status : Connected, uptime=3852969s, LastConnectionError : ERROR_NONE
  Time started : Sat Jan 17 18:10:33 2015
MaxBitRateDown : 10000000 bps (10.0 Mbps)   MaxBitRateUp 1000000 bps (1.0 Mbps)
ExternalIPAddress = 99.239.*.*
 i protocol exPort->inAddr:inPort description remoteHost leaseTime
 0 UDP 56724->172.29.0.19:56724 'Teredo' '' 0
 1 UDP 64182->172.29.0.19:64182 'Teredo' '' 0
 2 UDP 63492->172.29.0.19:63492 'Teredo' '' 0
 3 TCP  7763->172.29.0.19:4242  'NAT-PMP 3862124' '' 0
 4 TCP 12115->172.29.0.73:4242  'NAT-PMP 3865835' '' 0
GetGenericPortMappingEntry() returned 713 (SpecifiedArrayIndexInvalid)


So is this a problem with peplink or miniupnp or peplink using too old a miniupnp program then? Just want to make sure I'm bugging the correct dev team Very Happy
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1469

PostPosted: Tue Mar 03, 2015 1:36 pm    Post subject: Reply with quote

1) if peplink is using miniupnpd version 1.2, that is an issue
several security bugs have been fixed since

2) it doesn't explain why the peplink miniupnpd is not responding to the SSDP M-SEARCH packets.
According to your observations, it does send NOTIFY but that is not engough...

A UPnP device should :
1 - send periodically (every 30s for example) NOTIFY packets to multicast 239.255.255.250:1900
2 - respond to M-SEARCH sent by clients (control points) to 239.255.255.250:1900
The response is directly sent to the sender (no multicast)
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpc Bugs All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP
© 2007 Thomas Bernard, author of MiniUPNP.