miniupnp.tuxfamily.org Forum Index miniupnp.tuxfamily.org
The forum about miniupnp and libnatpmp
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

miniupnp trying to add port forwards to my tv tuner

 
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpc Bugs
View previous topic :: View next topic  
Author Message
adam2104



Joined: 18 Jun 2010
Posts: 1

PostPosted: Fri Jun 18, 2010 4:20 pm    Post subject: miniupnp trying to add port forwards to my tv tuner Reply with quote

This is a strange one. My environment:

Macbook Pro, running OS X 10.6.4.
Transmission bit torrent client, version 2.00
TV tuner - HDHomerun - a network attached tv tuner (supports upnp)

I'm attempting to allow Transmission to automatically map the necessary ports via NAT PMP. My home router is NOT upnp compatible, but it does support NAT PMP. When I start up Transmission, it sends out both upnp and nat pmp requests. What I'm seeing is that my TV tuner is responding to the "rootdevice" upnp request. Upon getting that, Transmission attempts to do port forwards to the device. It gets a 404 back from the tuner, but Transmission still thinks, via its debug log, that the mapping was successful when it wasn't.

I took a packet capture of the exchange, its available here:
http://dl.dropbox.com/u/313271/bad-upnp-mapping.pcap

Details:
Macbook Pro - 172.28.1.23
HDHomerun - 172.28.1.3

UPNP broadcast for "rootdevice" in packet 4
Response from HDHomerun in packet 5
Attempt by Transmission to forward ports on my tv tuner in packet 39
404 negative response from tv tuner in packet 42

I've gone through the data and I can't see where the tv tuner is indicating it is a router (as expected), so I'm at a bit of a loss as to why Transmission is attempting to map ports on it.

Suggestions?
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1525

PostPosted: Mon Jun 21, 2010 10:35 am    Post subject: Reply with quote

I guess Transmission is not checking the return value of the UPNP_GetValidIGD() function which indicate if the UPnP Device detected is an IGD reporting as connected, an IGD reporting as disconnected or another UPnP device.
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpc Bugs All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP
© 2007 Thomas Bernard, author of MiniUPNP.