miniupnp.tuxfamily.org Forum Index miniupnp.tuxfamily.org
The forum about miniupnp and libnatpmp
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

minissdpd stops working after a while

 
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpc Bugs
View previous topic :: View next topic  
Author Message
arokh



Joined: 06 Mar 2011
Posts: 5

PostPosted: Sun Mar 06, 2011 1:11 pm    Post subject: minissdpd stops working after a while Reply with quote

I'm using minissdpd 1.0 on my OpenWrt router with MIPSEL CPU (WNDR 3700) in conjunction with miniupnpnd (1.5.20110302). This works fine until after an hour or so where it stops responding to clients. Doing an strace shows no activity when clients do discovery. Restarting the process and miniupnpd makes it work again.

I noticed minissdpd hasn't had updates for two years, is it dead or considered "stable"?
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1474

PostPosted: Mon Mar 07, 2011 5:24 pm    Post subject: Reply with quote

I considered it stable, but you may have found a bug...
I should have a look on this.
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
arokh



Joined: 06 Mar 2011
Posts: 5

PostPosted: Thu Mar 17, 2011 9:53 am    Post subject: Reply with quote

Find anything? There's certainly a bug somewhere.

My platform:

Linux 2.6.37.4 on MIPSEL cpu.
uClibc 0.9.32
minissdpd 1.0
miniupnpd 1.5.20110302
minidlna from CVS with minissdpd patch applied

I can run both miniupnpd and minidlna at the same time for a short while, then both stops working.

Even if I run just minissdpd/miniupnpd, miniupnpd will stop working.

Running miniupnpd/minidlna standalone works fine.
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1474

PostPosted: Thu Mar 17, 2011 10:49 am    Post subject: Reply with quote

I'm trying to run miniupnpd/minissdpd in debug (with -d flag) and see what happens.
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
arokh



Joined: 06 Mar 2011
Posts: 5

PostPosted: Wed Apr 13, 2011 1:38 pm    Post subject: Reply with quote

Good news, problem has solved itself. Guess you can chalk it up to a bug somewhere in OpenWrt, perhaps uClibc.
Back to top
View user's profile Send private message
miniupnp
Site Admin


Joined: 14 Apr 2007
Posts: 1474

PostPosted: Mon May 23, 2011 1:23 pm    Post subject: Re: minissdpd stops working after a while Reply with quote

arokh wrote:
I'm using minissdpd 1.0 on my OpenWrt router with MIPSEL CPU (WNDR 3700) in conjunction with miniupnpnd (1.5.20110302). This works fine until after an hour or so where it stops responding to clients. Doing an strace shows no activity when clients do discovery. Restarting the process and miniupnpd makes it work again.

I noticed minissdpd hasn't had updates for two years, is it dead or considered "stable"?

I just updated it today to add IPv6 support Wink
_________________
Main miniUPnP author.
http://miniupnp.tuxfamily.org/
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    miniupnp.tuxfamily.org Forum Index -> miniupnpc Bugs All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP
© 2007 Thomas Bernard, author of MiniUPNP.